Forum

Posted by
Sascha Nemecek  -  January 2012
Hi there,

I get the following error when trying to connect from a Roxen 5.1.185 Webserver to a MySQL 5.1.57 database:

> It is not possible to connect to mysql://*****:*****@localhost/<dbname>.
> (Mysql.mysql(): Couldn't connect to SQL-server: Bad handshake )


In the Roxen debug log, I found the following related message:

> File '/home/jonasw/src/mysql/mysql-3.23.49/_BUILD_RHEL5_64_2//share/mysql/charsets/?.conf' not found (Errcode: 2)
> Character set '#192' is not a compiled character set and is not specified in the '/home/jonasw/src/mysql/mysql-3.23.49/_BUILD_RHEL5_64_2//share/mysql/charsets/Index' file


Connections to a MySQL 4.1.22 and MySQL 5.0.67 database work. What can I do to resolve this problem? Any tips?

Another related question:
Why does Roxen even try to use an old mysql client version with a hard linked path in it? I also encountered this behaviour when trying to install the Roxen package on openSuSE 11.4.


Thank you for your help and best regards,
Sascha
 
Posted by
Matthew Hardy  -  March 2012
Have you set up a utf8 (UTF-8) database?
 
Posted by
Sascha Nemecek  -  March 2012
Thanks for your reply. AFAIK the charset of the DB has no implication on the behaviour. Still "Bad handshake".

Sidenote: Roxen 5.0.449 has the same problems.

Any other hints?


Best regards,
Sascha
 
Posted by
Matthew Hardy  -  March 2012
Try compiling pike with newer mysql client is one approach.

for example on debian:
sudo apt-get install libmysqlclient15-dev

Then use the pike from git...

Or, maybe you could try apt-get pike7.8 and link roxen to that pike and try the  mysql client.

Or, is the mysql password old_password() or password()
 
Posted by
Sascha Nemecek  -  March 2014
Short update on this issue:
I used the fourth option. Sitting it out ... :-D

With Roxen 5.4 the issues are solved. Thanks fly to the Roxen team!

Cheers,
Sascha
 
Posted by
Matthew Hardy  -  September 2015
Great
 
1
Search this thread: